Tag Archives: diverse

.ru vs .ua – part fünf

M-am mega agravat maxim in ultimele saptamani de cand n-am mai scris pe tema asta. Ba cat de incompetenti sunt rusii, it’s a fucking joke. Cat de greu e sa dai cu bombe non-stop pana nu mai e nimic sa-i potolesti pe ucraineni? De ce trebuie sa fii selectiv? Ca nu cre’ca duc rusii lipsa de obuze, bombe si ce-o mai fi de explodeaza dupa ce e aruncat la distanta.

Ailalta suparare e ca ma seaca maxim tupeul lu Zelensky cum latra el ordine la toata lumea, sa i se dea arme, sa i se faca favoruri si alte cele. Mai nou vrea sa se desfiinteze ONU ca nu-l ajuta destul. Al dracu pitic a vorbit el in parlamentul .ro si dupa a declarat ca e dispus sa inceapa discutii despre minoritatile romanesti din .ua, nu ca “hei, uite acum facem ceva” – ci doar ca “e dispus sa inceapa discutii”. Cum ziceam, Ucraina n-a fost niciodata prietena Romaniei, doar o tara cu politicieni golani.

Alta chestie care ma seaca maxim, e ca daca nu esti impotriva Rusiei, esti cu Rusia si esti dusmanul poporului. Nu exista notiunea ca poti fi si impotriva Rusiei si a Ucrainei. E musai sa fii pro Ucraina, ca altfel esti dusmanul planetei. De asta imi place mie internetul, ca se polarizeaza imediat intr-o extrema sau alta in functie de emotiile stoarese de presa. Si dupa aia toti politicienii miauna dupa cum e sentimentul, ca e gratis si asa isi asigura voturile. N-au plans romanii dupa negrii omorati in Ethiopia ca erau din tribul gresit, n-a fost nici un politician obfuscat pe tema asta. Plang romanii dupa ucraineni, imediat s-a obfuscat clasa politica.

Bai da sa mor daca-i inteleg pe rusi, ce mortii lor au de nu-i pisa pe astia intr-un mod din ala epic cum doar rusii poa’ s-o faca? Ca asta e tot ce vroiam de la razboiul asta, niste distrugeri epice de care sa am ce povesti la nepoti. O nucleara in Kiev ar face minuni si l-ar linisti instant pe batausul ala de Klitschko de e primar acolo, i-ar scoate instant toata jmecheria din cap. Si la fel si lu Zelensky asta, ca pare ca sta mai mult pe acolo prin oras. Sau doua-trei sa fie siguri ca devine instant camp arabil orasul ala.

Fucking disappointing.

.ru vs .ua – part quattro

Mi-a dat prin cap citind postarile trecute ca parca din ele suna c’as fi pro-rus un pic (mai mult). In principiu sunt anti-ucrainean, si pe principiul asta, tin cu aia care le da bucata astora.

Un alt fel de a vedea lucrurile, ca si o analogie, Ucraina e o firma. Care pe diverse planuri competitioneaza cu firma numita Romania. Cateodata cinstit, cateodata mai putin cinstit (gen incercat sa fure din Dunare la propriu prin mutarea balizelor de frontiera). Angajatii acestor firme sunt populatia efectiva. Acum, asta face ca lucrurile sa fie simple si sa impac si capra si varza: imi pare rau ca angajatii de la firma rivala raman fara job, dar ma bucur ca firma rivala probabil o sa dea faliment, si atunci mai ramanem fara un competitor. Pe unii din angajati o sa-i angajeze romanii, pe altii polonezii, pe altii nemtii si tot asa. In general firmele dispar, angajatii isi cauta joburi in alta parte.

Asta e un aspect. Alalalt aspect e ca imi place ideea asta de anarhie si daca e sa fie anarhie, sa fie ca la carte si preferabil nu pe aici si peste granita :))

Acu sa revin la dilemele mele existentiale cu Ucraina: cum sloboz ditamai puterea (conventionala si nucleara) nu e capabila sa pisa o tara semnificativ mai mica? De ce ii bombardeaza doar asa putin si nu-i niveleaza cum i-au nivelat pe sirieni? Care e schema? Ca e mult mai usor aici sa aduci toate bombele de care ai nevoie si cate ai nevoie sa faci o campie si mai campie de cat e acum Ucraina? De ce mai exista Odesa? Cate de mare e Mariupol asta de nu poa sa dea 3-5 bombe din alea masive sa-l niveleze?

In continuare sunt dezamagit de prestatia rusilor, chiar pica de prosti in fata lumii. Pe de alta parte, incapatanati ai dracu’ ucrainenii astia. Daca n-as considera Ucraina inamicul Romaniei, mai ca imi vine sa le zic “Bravo ba golanilor, sunteti fix mardeiasi asa cum va credeam!”.

.ru vs .ua – part tres

E greu sa gasesc cuvinte pe cat de mult ma supara performantele rusilor pana acum. Ma simt ca atunci cand ma duc la cinema sa vad un film ca a avut un trailer super bun si de fapt filmul sa fie o basina totala si trailerul sa contina de fapt toate scenele misto din film. Macar asa ma duc acasa, bag 10 torrente de filme pe care poate as fi dat banii pe ele numai sa ma racoresc de la dezamagirea de la cinema. Da aci e mai greu sa ma duc sa-i dau doua perechi de palme lu’ Putin. Mai ales ca nici n-am dat bani pe invazie.

Ma asteptam sa fie epica invazia asta, russian style, cu bombardat tot ce le sta in cale zi si noapte, sa faca campie din orice blocuri sau orase le ieseau in cale. Si astia ce fac? Mai pe ici pe colo niste obuze, aviatia lor abia ca e prezenta. Unde sunt toate bombele alea cu submunitii de niveleaza tot in jur? Unde sunt termobaricele gramada? Unde e FOAB-ul? Unde’s rachetele de croaziera? Unde’s rachetele alea mai dumb, dar pe care le lansezi cu miile sa linistesti tot in zona unde cad? Unde e apararea antiaeriana?

Argh! Maxima dezamagire. Fix ca’n’trun trailer din asta e tot ce se intampla in Ucraina: la exercitii au lansat mai multe bombe ca in invazia asta. Macar la filme trailerul are scene din film, da astia parca au facut trailerul inainte si dupa aia cu ce bani le-a ramas s-au apucat de film.

Fucking annoying.

Partea buna e ca a castigat Romania niste capital din asta de ospitalitate si omenie, ca au primit pe toti de au ajuns la frontiera, au salvat si niste indieni si alte natii de care mai ziceau astia la stiri.

N-are si Putin asta cativa comandati capabili la bataie sa stie cum sa conduca o lupta si sa castige? Chiar asa sa fie toti praf si pulbere? Ca daca e asa, inseamna ca asta doar s-a laudat ca stie bataie da de fapt nu stie si putem sa mergem toti sa-l batem ca ne-a pacalit.

Fuck!

viata cu pisici

Din categoria “am ajuns la punctul ala in viata cand am pisici” :))

Prin 2020 m-am pricopsit cu 2 pisici biberonezi. Adica abandonati de mici si hraniti cu biberonul ca mama pisica nu a fost de gasit :(

Unul e alb/negru si cu o mecla din aia judgy cand te uiti la el din profil. E singurul pisic pe care l-am vazut vreodata sa vrea sa ia oameni in brate. Adica daca te lasi jos si vrei sa-l iei in brate, pune asa labutele pe tine si dupa aia te ia te gat si incepe sa toarca in majoritatea cazurilor. Zici ca a fost tinut in brate toata viata si altceva nu stie. Pentru ca are fataul ala asa judgy, l-am botezat Spock :)

Alalalt e complet negru, si acu la aproape doi ani i-a albit un pic blana pe burta. Are o blana din aia super fina si stufoasa. Asta nu prea stie el cu luatul in brate, da ii place sa fie tinut in brate cu roatele in sus si mangaiat pe burta. E super fericit cand e tinut asa. Si mai are o chestie, se pune pe tine si te framanta, zici ca a fost brutar sau patiser intr-o viata anterioara. Are doua nume ca e mai special. Numele oficial e Maslin ca e negru asa ca o maslina din aia kalamata. Alalalt nume e Slowness ca e un pic slow. Nu stie el multe, da si cand isi pune in cap ceva… nu se lasa pana nu ii iese.

Asa, cand erau mai mici am zis sa fie dormitorul cat-free ca par de pisica, si doua pisici lasa si mai mult. A fost mega complicat ca dimineata inceapa Slowness recitalul la usa – mieuna de parca se sfarsea asa.Si initial am ajuns la un compromis, dimineata le dadeam un pic drumul in dormitor si ii ademeneam inapoi cu mancare.

Pana intr-o zi cand Slowness s-a prins cum sa deschida usa. Si nu oricand, ci intr-o dimineata din aia cand dormeam lin si m-a speriat maxim. Si uite asa s-a terminat perioada de dormitor cat free :))

Cel mai amuzant dinstre astia doi e Maslin, care nepricepand el foarte multe lucruri, deschide toate usile prin casa si dupa aia intra asa triumfator cu coada ai stufoasa sus. E super cute si funny, zici ca a cucerit vreun castel ceva :))

Acu ca au crescut si sunt destul de marisori, au deprins alte obiceuri. Spock vine dimineata si se baga cu capu pe langa perna ca vrea atentie, Maslin vine si framanta ce prinde.

Spock e carnat asa ca vine la 7, cateodata la 6. Slowness e cuminte si cum aude alarma la telefon vine la framantat, da nu inainte.

Si amandoi cand ajung acasa se pun pe spate sa-i mangai pe burta, de parca sunt caini. Si se alinta, si se intind.

Inaintea aveam telefonul plin cu meme-uri, acu fac ca prostu poze la pisici cand mi se pare cute. Mai si filmez, ca they do cute stuff.

E draguta viata cu pisici. Da mi-as dori sa nu mai mai trezeasca dimineata inaintea gainilor :))

.ru vs .ua – part deux

Well, this is unexpected. Ucraineni ii fac pe rusi intr-un mare fel.

Imi pusesem mari sperante in rusi c-o sa-i niveleze pe ucraineni, o sa zica “ups, noi de fapt vroiam sa-i speriem, no biggie”, da’ pare’se ca la comanda rusilor e unul incepator la strategie si care n-a jucat Red Alert sau StarCraft niciodata in viata lui. Si nici n-a citit vreo carte din asta de strategie si tactica militara.

Pai cum sa trimiti ma cate 20-30 soldati o data, inca 20-30 o data si tot asa si aia sa te astepte in buncare si sa iti impuste soldatii pana ii fac carne tocata? Ai uitat cum te-au tocat cecenii la fel in ’94-96?

La fel si cu apararea antiaeriana. Au ramas rusii fara curent la sateliti si nu poa’ sa mai vada ce au si unde ucrainenii? N-au si ei un satelit geostationar in zona aia sa se uite la el ca la televizor sa vada tot ce misca ucrainenii? Sau macar nu stiu, o drona ceva sa faca 2-3 poze si sa le trimita pe Telegram la comandamentul lor?

Cred ca si in “War for dummies – the short version” scrie ca e musai sa detii superioritate aeriana cand invadezi o tara sa poti aduce repede undeva trupe si provizii, nu trebuie sa te duci la academie militara sa inveti asta.

Alta treaba care-mi scapa e cum sistemele de aparate antiaeriana sunt tinute oprite si le pisa aia cu dronele, care nu-s invizibile pe radar si le simti de la zeci de kilometri.

Cred ca isi dau cu tesla in coaie inginerii aia de le-au gandit sa fie super jmechere, sa prinda tot felul de chestii zburatoare, da Ivan nu le porneste.

In toata tara aia, n-au gasit si astia 2-3 baieti de se pricep la StarCraft sa le arate cum se face o invazie calumea? La 150k de soldati desfasurati faceai un Zerg rush de toata frumusetea.

Dupa aia e alalalt capitol din “War for dummies – the short version” in care explica de ce o insurgenta in mediu urban cand vrei sa nu omori prea multi oameni e pretty much mission impossible. Si daca nu stii sa citesti, tot poti sa te uiti pe Youtube cum americanii n-au reusit sa pacifice nimic in 20 de ani in Afganistan si Irak in orasele mari, ca omorau unu si apareau doi.

Dupa aia e partea de propaganda unde ucrainenii castiga detasatat. Ii trolleaza maxim pe rusi. Io’s acu mega curios cate crize de nervi o fi facut Putin la cat trolling si-a luat. Si la media la fel, ucrainenii forta, tipa presedintele ala al lor la toti si peste tot. Spectacol maxim.

Pretty disappointing so far. E ca atunci cand Steaua ia bataie de la Dinamo. Pai e frumos?

Da hai, ca incepu o saptamana noua, incepe o luna noua, poate devine mai interesant razboiul asta.

snitel in pita

Aseara m-am dus la OMV sa bag niste gaz. Am injurat in gand ca s-a facut benzina 7.93, si m-am dus sa platesc. Cat asteptam sa termine acolo o tanti cu casiera, m-am uitat la ce aveau de haleala si vad snitel in pita. Si zic sa iau, ca tot imi era un pic foame, planuind sa mananc un pic din el ca sa nu sar calul cu carbohidratii seara.

Imi zice casiera ca trebuie sa-l incalzeasca si tocmai bine, ca dura ceva incalzitul, m-am dus si la baie. Da stiu, detaliu care nu trebuia mentionat, da’ nu costa sa scriu aci :))

Imi da pita cu snitel calda, ma duc in masina, pornesc si tot era acolo un semafor care tinea mult, zic sa iau o gura doua de mancare.

Dupa prima gura, m-am teleportat cu aminitirile pe undeva cred ca prin clasa a cincea sau a sasea cand mergeam la un fast-food acasa inainte de scoala, ca faceam dupa-masa ore, si imi luam hamburger. Care era tot asa o pita in care se punea o bucata incalzita de carne tocata facuta pe plita, ceapa, rosii si ketchup si maioneza. Si dupa se baga la microunde vreun minut asa cred, ca nu mai tin minte tot. Si era mega bun ce iesea.

Si pita asta avea fix gustul ala, care atunci era super bun, ca ma duceam destul de des la cumparat hamburger :))

Nu mi-e super clar cum sa descriu, da m-am bucurat nespus, ca am descoperit un gust din copilarie. Acu mi-e complicat sa mananc ceapa ca ma fute maxim la stomac, da aseara am mancat pana la ultima bucatica din pita aia, ca era si buna, da mai mult pentru ca avea gustul ala fix cum trebuie.

Mi-ar mai placea super mult sa mai gasesc si niste rosii care sa aibe gustul “ala”.

onenote & evernote

Multa vreme am folosit Evernote sa-mi stochez diverse notite pana cand acu cativa ani mi s-a parut ca e cam scump pentru ce-l folosesc si am renuntat la subscriptie, si am ramas cu aia gratuita.

Intre timp aparuse si OneNote de Mac si m-au cam convins din filmuletele de prezentare ca o sa fie ca Evernote sau chiar mai bun. Si bonus, nu costa bani. Si-am zis ca m-am scos. Mai ales ca tot aveam Office, OneNote era manusa pe treaba asta.

Intre timp am trecut la luat notite pe caiete/agende de la Muji, si acu vreo un an si ceva mi-am luat Remarkable2 pe care am tot scris. Ca e misto sa scrii pe o agenda care nu se termina niciodata :))

Insa in ultima vreme am avut nevoie sa structurez niste informatie intr-un document super lung. Si am inceput in OneNote pana a inceput sa gafaie de la text si imagini. Sa nu mai zic ca a ramas fara internet vreo cateva momente si nu s-a mai prins care versiune de document e aia ultima: locala sau de la MS din server, si a ramas cu “Conflicting versions” fara nici un motiv. Dupa care am descoperit ca nici nu pot adauga “horizontal ruler”, gen asa, da pe toata lungimea (<hr/> ar fi in HTML):


Si pentru ca era foarte important sa am separatorul in document, am bagat totul in Evernote si mi-am adus aminte de ce-mi placea Evernote: este foarte bine facuta aplicatia si arata bine, nu stiu cum sa zic, parca iti face placere sa scrii in ea.

Ce ma seaca la OneNote e ca are o idee super buna de a avea caiete cu sectiuni si sectiunile au pagini, care pagini pot fi infinite ca si lungime, dar pot fi sparte pe topice. Dar formatarea textului e asa, super spartana, ca un copile iesit dupa ce Notepad si Wordpad s-au imbatat si s-au futut nestiind ca’s rude.

Si uite asa, am iar nustiucate locuri unde scriu lucruri si o sa fie distractiv cand o sa le caut si-o sa uit pe unde le-am pus.

.ru vs .ua

Cand am auzit ca rusii vor sa le sparga fata si sa le dea muie cu furtunul de pompieri ucrainenilor, m-a luat bucuria.

De ce m-a luat bucuria? Pai ca Ucraina nu a fost niciodata prietena cu .ro, ba chiar mai mult, inainte sa intre .ro in UE/NATO/slbz, erau tari in gura, au ciordit insula Serpilor, au incercat sa mute granitele pe la Dunare mai mult la ei. Golaneli din astea documentate. Ca ei erau multi, romanii putini si plm, pleznea jmecheria in ei.

Da cum lucrurile nu poa sa fie simple, s-au bagat si americanii sa tina cu ucrainenii. Nu ca le-ar pasa prea tare de ei, ca probabil 99.99% din ei habar n-au unde e tara asta pe harta, da e pe fenta aia cu “daca-i enerveaza pe rusi, sigur, tinem si cu chinezii la o adica”. Ca asa e politica internationala, ai boala pe unu’ si faci tot ce-ti sta in putinta sa-l enervezi.

UE s-a trezit si ea ca are ceva de zis dupa ce nu s-au inteles americanii si rusii la Geneva. La modul ala ii doare in pula si pe americani si pe rusi de UE. Si daca ar fi de razboi pe bune intre americani si rusi, fara proxy-uri din astea de neam prost cum e acu via .ua, tot nu i-ar baga in seama pe europeni, desi ei ar suge-o cel mai tare. Ar fi o treaba din aia cu “mucles, ca vorbesc adultii”. Si cand zic europeni, zic si romani, ca si noi tot europeni suntem. Si probabil am fi primii. Si nu e genul de chestie la care mi-as dori ca .ro sa fie fruntasa :))

Obviously, UE tine cu americanii ca asa e la moda, ca altfel ii doare si pe astia in pula de ucraineni.

Si cum ziceam mai pe la inceput, ca ucraineni sunt doar cu golaneala, ca altceva nu stiu, mascariciul ala de presedinte al lor, s-a dus sa planga pe la toti sa-i dea arme ca vine ursul si-i fute. Si cand n-a primit destul, ca inceput sa chitatie, ca vai, ca o sa fie nasol, ca are nevoie. Si tot circul asta a culminat cand s-a trezit cu tupeu de borfas sa le bata obrazul nemtilor ca de ce i-au trimis doar casti si nu si arme. Ca simtea el ca merita mai mult. A mai primit un Nein de nemti, asa de control.

O alta schema cu Ucraina de enervare a rusilor, care e de foarte mult timp, e cu insistenta americanilor asupra europenilor sa nu opreasca Putin gazul pe la ucraineni, ca e musai sa treaca si pe acolo sa-si ia si pisatii aia dijma pe ceva ce nu merita. Toata distractia asta a culminat cu Trump care s-a oferit sa le vanda europenilor Freedom Gas, sa nu mai fie dependenti de rusi :)) Si acu tot pe combinatia asta cre’ca merg americanii, au gasit o schema prin care sa vanda niste gaz scump, dar “free” in UE, ca libertatea asta nu e ieftina, nu cade din cer.

Anyway, eu tot sper sa-si ia ucrainenii la muie de la rusi pana li se umfla ochii ca nu mai poa sa respire de ce adanc le-au bagat aia pula pe gat. Cu putin noroc, poate nici nu o sa mai fie nevoie de discutam despre Ucraina in cativa ani daca-i pisa rusii suficient de bine.

Si dupa ce se intampla asta, poate mai scade un pic pretul la gaze naturale.

Pace cartierului.

lucratul la o agentie UE

In 2020, pe la inceput de pandemie ma gandeam ca hai ca poate o sa fie pe bune pandemia asta, vine apocalipsa si zic sa nu mor prost sa nu vad si eu cum e sa fii contractor la UE.

And how luck would have it, cum zic prietenii mei de peste ocean, am dat de unii de cautau pe cineva pe security si in acelasi timp sa faca mai multe lucuri: de la endpoint la network si ceva IAM pe la mijloc. Interviul in sine a fost o discutie de o ora in care toti aia prezenti m-au intrebat daca am lucrat cu X, Y si Z si sa le dau niste exemple. Destul de pe repede inainte toata treaba.

Contractul asta era B2B si era un trenulet asa de firme intermediare pana la clientul final, ca deh, toata lumea trebuie sa manance ceva.

Dupa un pic de certat cu firma prin care urma sa facturez pe aia cu care faceam treaba la agentie, ca initial mi-au dat un contract prin care trebuia sa vin cu bani d’acasa daca stranutam in directia gresita sau nu clipeam cum trebuie si alte clauze contractuale sa zicem interesante, am reusit sa ne intelegem.

Vreo trei luni am lucrat “remote” pe un proiect “air gapped” :)) Bine, sunt un pic carcotas, ca a fost frumos, am citit documentatie pe bani de Europa la costuri de .ro. Si nici nu mi-a venit somn cand citeam cum mi se intampla de obicei cand citesc.

Proiectul presupunea si munca on-site – ca security & stuff.

Si ajung eu in orasul unde era agentia intr-o miercuri ca joi trebuia sa fac treaba la prima ora. Joi la prima ora n-am facut treaba ca nu eram pe lista de intrare. Si nici urmatoarele doua saptamani n-am fost pe lista de intrare. Si am mai muncit un pic remote sa citesc documentatie si sa am teleconferinte cu diversi oameni povestindu-le ce chestii jmechere o sa le fac dupa ce ma lasa inauntru.

Intr-un final glorios, m-au pus pe lista de intrare. Mi-am frecat palmele, si zic, gata, sa facem si treaba pe bune, ca de vorbit toata lumea se pricepe.

M-am dezumflat repede, ca din cauza de securitate, nu puteam sa-mi pun laptop-ul in retea si sa fac treaba, era musai sa folosesc un calculator de-al lor. Care avea nevoie de utilizator si parola. Pentru care a mai durat o saptamana si un pic sa le primesc.

Si dupa ce le-am primit si le-am scris cu chiu cu vai pe o tastatura frantuzeasca, m-au pus sa schimb parola. Pe o tastatura frantuzeasca si cu OS-ul pus pe tastatura QWERTY. Sa zicem ca nu a fost asa amuzant pe cat suna.

Dupa ce m-am logat pe calculator, a mai durat cred ca vreo saptamana asa sa mearga ping-ul.

Pentru cine mai zice ca in vest lucurile sunt organizate, sa suga preventiv o ceapa.

Asta a fost inceputul.

Pentru o entitate care avea treaba cu IT-ul, era foarte paranoia cu securitatea fizica. Primii oameni pe care i-am vazut cu gard electric in jurul sediului. Intre alte doua garduri.

Dar nu asta era problema. Ci faptul ca in fiecare dimineata trebuia sa arat buletinul la un paznic, care sa vorbeasca cu alt pazic sa deschida o usa. Dupa care sa dau iar buletinul la altul sa ma scrie pe o foaie. Dupa care sa trec printr-un detector de metale si sa bag rucsacul la X-Ray. Dupa care sa dau buletinul la alti oameni, care sa-mi ia amprentele si sa-mi dea o legitimatie sa pot sa deschid o usa.

Acu, cu detectorul de metale era o schema: daca aveai ceva bluza cu fermoar trebuia data jos, daca nu, nu trebuia. Si uite asa am purtat aceeasi bluza in fiecare zi, care n-avea fermoar, doar de-al dracu’ sa nu le dau satisfactie cu regulile lor de cacat.

Astia de la security erau mai mult pe principiul noi muncim, nu gandim. Si incercau sa fie amuzanti prin a schimba regulile de intrare. Cea mai tare chestie, not. Adica ori trebuia lista data zilnic, ori saptamanal. Sau cardul primit mergea la niste usi intr-o zi si a doua zi nu mai mergea la aceleasi usi… Cam in fiecare saptamana jucam un joc din ala in cap in care eram curios daca o sa ajung la birou sau o sa raman blocat pe la vreo usa :))

Asa, cu securitatea fizica, sa continui. Intr-o zi ajung acolo, trec de primii doi, dau sa trec prin detectorul de metale dar in el era unul pus care-mi face semn sa ma opresc. Se da in spate si imi face foarte protocolar asa semn sa trec. Se uita la mine ca la butelie. Si il intreb care-i combinatia, ca de obicei era unul singur acolo. Si imi raspunde senin: sa fim siguri ca treci prin detectorul de metale. Ma uit la el, ma uit la gardul din stanga si dreapta detectorului si ii zic ca n-am pe unde altundeva sa trec. Asta fara sa clipeasca: da, dar trebuie sa fim siguri. Am mai clipit o data ca nu puteam sa-l injur.

Tot asa intr-o zi, in timp ce-mi scanau suba de iarna ca nu cumva sa introduc ceva ilegal in curtea lor, se opresc, mai cheama pe vreo doi si panica mare. Ca e ceva in suba si ei sunt de parere ca e un cutit. Eu zic, ba n-am cutit, ca nu-mi trebuie. Ei nu, ca e metalic si uite e ascutit pe scanner. Si deschid buzunarul la geaca sa le arat la destepti ca nu e ce cred ei ca e. Si era telefonul care se pusese la miscare cumva pe o muchie si statea in picioare. Acu mi-ar placea sa pot sa injunghii pe cineva cu iPhone-ul, dar nu prea se poate :))

Din motive care-mi scapa si in ziua de azi, aveau o obsesie cu apa la tine. Nu ca era ilegal, da cand le aparea apa pe ecranul ala de la X-Ray, sa moara Bibi, incepeau sa se agite de parca o gasisera pe Elodia. Distractia asta a culminat intr-o zi cand m-a pus unul sa deschid sticla de apa sa fie el sigur ca e apa inauntru…

Intr-o alta zi, tot inteligentii astia de la paza au zis sa organizeze un exercitiu de incendiu. Si in loc sa dea alarma si sa astepte sa iasa lumea, au dat c-o grenada fumigena in sala de mese, “sa fie real” – dupa spusele lor. Si a fost bine, ca le-a iesit la final e ca au scapat peste 90% din oameni din cladire, “grate success” si aia a fost.

Asa, pe partea cu apasatul butoanelor n-a mers mai grozav. Ca nu e cum stiam eu cu statul din .ro, unde faceai treaba, oamenii erau multumiti ca merge, mai scriai acolo si un pic de documentatie si iti vedeai de viata.

Nu, aici prima oara scriai un eseu despre ce vrei sa faci si il trimiteai la revizuit. Si primeai inapoi comentarii foarte pertinente precum:

  • culoarea fontului nu este corecta
  • la paragraful 2 nu a fost indentata corect o lista
  • pe FTP se downloadeaza, nu se transfera
  • nu se face update de software, se face upgrade de software

Si corectai ce ai scris gresit, si mai trimiteai o data. Intr-un final ti se aproba esesul si puteai sa apesi niste butoane.

Cireasa de pe tort? Toate comentariile astea le primeai intr-un Excel in care trebuia sa scrii si ca ai remediat problema. Si dupa ce trimiteai documentul nou cu tot cu Excelul, se stabilea ziua de revizuit in care intram multi oameni intr-o teleconferinta si era asa o schema: le aratam Excelul, unde ziceam ca am remediat, dupa care le aratam documentul unde se vedea ca am remediat si dupa aia scriam in Excel ca intr-adevar s-a remediat ce era de remediat. Si la fel scriam si in document ca am remediat ce era de remediat folosind comentarii.

Macar nu faceam conferinte cu video, ca probabil m-ar fi concediat daca ma vedeau cum le arat pula la fiecare comentariu cretin pe care trebuia sa-l justific…

Asa am aflat ca e nu pot sa ma duc de capul meu cu un computer sa-l conectez pe seriala la un echipament, ca daca pun virusi pe echipament la 9600bps? Nu mai bine ma supravegheaza cineva cand dau comenzi? Si mai bine ca cine ma supraveghea nu avea treaba cu IT-ul? Because fuck logic, that’s why.

Atatea chestii retardate la un loc n-am vazut niciodata. Si nu ca n-am vazut, da’ erau la nivelul ala la care nici nu te gandesti ca ar putea fi.

Proiectul la care lucram in teorie era misto, in practica a iesit o struto-camila atat de complicata ca sa dea dracii cand s-o strica ceva ca nimeni n-o sa stie de unde s-o apuce. Si nu neaparat asta, da am descoperit ca’s oameni de operatiuni care nu stiu sa citeasca un mesaj de eroare si sa-l interpreteze. Si un sa zicem stack trace, din alea simple, gen “Ce inseamna Connection Refused”. True story :(

As mai fi scris, da imi incalc zecile de pagini de NDA pe care a trebuit sa le semnez.

Anyway, acu pot sa o bag p’aia ca am si experienta la UE :))

ios-xe port channels & switchports

Am avut prin August un mic proiect sa bag niste Layer 2 peste balta la un client. In general, daca nu am constrangeri, folosesc Juniper pe switch-uri managed L2/L3 din motive de obisnuinta, familiaritate etc.

Anul asta, din cauza de pandemie si timpi de livrare mari, peste 4 luni in medie, am pus niste Cisco Catalyst cu IOS-XE.

Mno, pentru redundanta & stuff, sunt mare fan bundle-uri de X x 1GE sau X x 10GE (in functie de nevoi & stuff).

Pe Juniper, la modul cel mai simplu, un port channel se cheama o interfata ae (aggregated ethernet) si se configureaza in doi pasi.

Prima oara ii zici la interfata fizica din ce port-channel face parte:

ge-0/0/0 {
    description "to xyz vmnic0";
    ether-options {
        802.3ad ae1;
    }
}

ge-1/0/0 {
    description "to xyz vmnic1";
    ether-options {
        802.3ad ae1;
    }
}

Si dupa configurezi si interfata de port channel:

description "to xyz";
mtu 9216;
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members [ v101, v121 ];
        }
    }
}

Easy peasy lemon squeezy.

Cu Cisco nu prea am avut treaba in ultimii ani, si am zis ca hei, trebuie sa fie la fel din ce mai tineam eu minte de and era la moda sa fac PAgP pe IOS clasic.

E, e cam la fel si pe IOS-XE. La nivel de interfata ii zici:

interface TenGigabitEthernet1/1/3
 channel-protocol lacp
 channel-group 1 mode active
 lacp rate fast
!
interface TenGigabitEthernet1/1/4
 channel-protocol lacp
 channel-group 1 mode active
 lacp rate fast
!

Si dupa configurezi interfata PortChannel1

interface Port-channel1
 switchport trunk allowed vlan 101-121
 switchport mode trunk
!

E, si te astepti ca la un “sh ru” sa vezi prin configuratie fix acelasi lucru.

Dar nu, IOS-XE e cu “surprise motherfucker”, si zice asa:

interface Port-channel1
 switchport trunk allowed vlan 101-121
 switchport mode trunk
!
interface TenGigabitEthernet1/1/3
 switchport trunk allowed vlan 101-121
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
 lacp rate fast
!
interface TenGigabitEthernet1/1/4
 switchport trunk allowed vlan 101-121
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
 lacp rate fast
!

Cand am vazut asta, zic ma oi fi fost io obosit si am scris gresit, si am bagat configuratia si la interfata si la port channel. Si m-am mancat in cur sa “repar” de la distanta treaba asta. Si am sters configuratie de switchport si trunk de pe te/1/1/3. N-a fost chiar cea mai buna idee a mea.

Dupa ce am reparat printr-o sesiune de TeamViewer problema, in sensul ca am facut de la zero toata configuratie de port channel, m-am dus sa ma culc ca se facuse tarziu la mine.

Fast forward vreo 2-3 saptamani, iar a trebuit sa umblu un pic la switch-uri sa mai adaug ceva VLAN-uri, si bam, iar configuratie de switchport pe interfetele din port chanel. Si eram, ba da am sters si-am pus la loc. Ce mortii ma-sii se intampla. Si atunci mi s-a aprins un pic beculetu, si zic ia sa vad daca adaug un VLAN pe interfata de port channel, se pune si in configuratie la interfetele care formeaza port channel-ul?

Raspunsul e da. Si uite asa am invatat eu ca IOS-XE mirroreaza configuratia de pe PortChanel pe interfetele prinse in port chanel.

Nu e mare inginerie treaba asta cu un port channel intre 2 switch-uri, dar lucrurile par complicate cand nu prea ai parte de experienta pe niste echipamente si lucrezi cu ele doar din joi in pasti. Exista si un termen sa zicem stiintific pentru asta: skill fade. Si problema e ca ti se pare ca stii, da de fapt nu prea :(